QGIS Help


Disclaimer: This guide is included in our Help Portal as a courtesy to better understand how to use QGIS, but we are not affiliated with QGIS or any of the links provided below.

Note: Documentation links provided here are for QGIS version 3.4, which is the current long-term stable release and the version we recommend to use for best compatibility. 



QGIS has its own documentation portal. To choose a topic you can select one within the portal. 


QGIS User Guide 


QGIS Training Manual



For popular topics, these links may help:


Creating a new Layer from a Shapefile


Working with the Attribute Table


Labels



______________________________________________________________________


Some helpful guides:



How to export attribute data from QGIS:

1. Open the data in your QGIS workspace


2. Check to see if there is a filter active (such as "year" = '2019') that will affect which features are visible


3. Click on the layer in the legend then use the Select Features tool to select the features you want to export


4. Optional: open the Attribute Table to view the selected features. Use the button at the bottom right to switch between table view and form view.


5. Right click on the layer in the legend and go to Export, then Save Selected Features As


6. When the dialog box opens, click the three dots to the right of where it says Filename. This will open a window called "Save Vector Layer As" where you can navigate to the folder you would like to save the file into. Once you have chosen the save location, enter a name for your file and click "save". The "Save Vector Layer As" window should close, and the dialog box should now show the filepath for the new document in the Filename field.


7. Select csv as the file type. You can leave all the other options as the default. There is an option enabled that will show the data table in the legend of the workspace once the export is complete, you can choose to disable this if you want.


8. The file will export to the location you specified. You will see a blue loading bar at the bottom of the screen with the export progress. When the export is successfully completed, a green bar will show up at the top of the screen telling you it was successful and giving you a link to the file location. 
 
9. If you try to open the csv file while it is already in the legend of your QGIS workspace it will only let you open a read-only copy. This is fine if you do not plan to make changes to the file.





How to use the QGIS Georeferencer tool:


Use this if you are viewing an orthophoto or raster file with an unknown or missing CRS/projection



In your QGIS workspace, first open several "reference layers" in QGIS such as hydro_area, cadastre_geometry and roads.

Open the Plugins menu and Select Manage and Install Plugins, then search for Georeferencer GDAL. Click the checkbox next to it to enable the plugin.
Open the Raster menu button and select Georeferencer.
The Geoferencer opens in a new window.
In the Georeferencer window, go to File > Open Raster then navigate to the file you would like to georeference. The orthophoto opens.

In the Georeferencer window, open Settings > Transformation Settings
Enter the following into the parameters:
Transformation type: Thin Plate Spline
Resampling method: Nearest Neighbour
Target SRS: Enter the projection you would like to save it as. EPSG 3401 is what Munisight usually uses for Alberta data.
Output raster: the filename will automatically generate as 'oldfilename_modified.tif", you can change the filetype to .sid instead if desired by editing the filename, changing the "tif' part to "sid".
Compression: none
Check the box for "Load in QGIS when done"
Close the settings menu.

In the Georeferencer window, go to Edit > Add Point
Look for a spot on the ortho that you can match to a location in the reference layers, such as a road intersection or a lake.
Click to add a point to the ortho.
Click the "From Map Canvas" button, then select the same location in the reference layers.
Do this at least 3 times so that you have at least 3 matching sets of ground control points.
Click the green arrow to "Run the Transformation". It should automatically open your georeferenced ortho in the QGIS window.
If the georeferenced image does not seem to match the reference layers, you can add more ground control points or delete mismatched points using Edit > Delete Point and clicking on the point you want to delete.
The image is saved when you run the transformation, so when you are satisfied with how it looks you can close the georeferencer window.

You can try as many times as you like, because as long as the new file has a different filename, which it does by default, it will not change the original file. 




If you have any other questions or concerns, please do not hesitate to contact Munisight Support and we will help you with your request.